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1.

Overview

The Lorby-SI “AxisAndOhs” app is designed to manage your joysticks and other controllers individually and
automatically for each aircraft that you fly in your simulator. AxisAndOhs will remember each joystick
assignment for each aircraft livery. If you already have an assignment for another aircraft of that type in the
database, AxisAndOhs will assume and apply the same assignments.
All joystick movements are then routed through the app and control your aircraft in the simulator directly. No
other control assignments are required, neither in-sim nor from an external module.
Lorby “Axis And Ohs” is compatible with
FSX boxed with Acceleration
FSX:SE
P3D 2.5
P3D 3.x
P3D 4.x

2.
2.1

Installation
Distribution

Lorby AxisAndOhs is distributed as a self-extracting installer package.

2.2

Installation

– Please use the installer intended for your sim:
– Please use the installer intended for your sim:
– FSX Acceleration boxed or dual install with SE: LorbyAxisAndOhs_Install.exe
– FSX SE stand alone: LorbyAxisAndOhs_SE_Install.exe
– Prepar3D V2.5: LorbyAxisAndOhs_P3D_Install.exe
– Prepar3D V3.x: LorbyAxisAndOhs_P3D_V3_Install.exe
– Prepar3D V4.x: LorbyAxisAndOhs_P3D_V4_Install.exe

Running the installer:

On the first page you may select optional installation targets:
– “Start Menu Shortcuts”: Lorby AxisAndOhs will be added to your Start Menu (advised)
– Selecting “Install” will begin the installation

2.3

Pause on task switch

Lorby AxisAndOhs is an external process. When you want to operate it from its own GUI, you must disable
“Pause on task switch” in the simulator.

2.4

SimConnect

Lorby AxisAndOhs relies on SimConnect being installed correctly on your computer. SimConnect is a part of
your simulator and it is set up automatically when you first install the simulator. No further installations are
required.
FSX only: In case SimConnect is not installed, and Lorby AxisAndOhs does not start up, giving you an error
message instead, you will have to install SimConnect manually:
– FSX boxed users can find the “SimConnect.msi” installation file either online or in the FSX SDK folder
“..\Microsoft Flight Simulator X SDK\SDK\Core Utilities Kit\SimConnect SDK\lib”
– FSX SE users find it here: “..\Steam\steamapps\common\FSX\SDK\Core Utilities Kit\SimConnect
SDK\LegacyInterfaces\FSX-SP1\SimConnect.msi “

3.
3.1

Operations
Starting the application

– Start your simulator
– Start the Lorby AxisAndOhs app
– Click on the green LED in the top menu bar
or open the “Connection” menu and select “Connect”
or set the app to “Connect automatically” in the same menu
– As soon as your aircraft has been detected and the simulation is running, you can start adding axis controls
and buttons.
The LAAO app will remember these settings for each aircraft
– To avoid conflicts with the controller settings in the simulator, the app has features to disable controllers in
the sim. You can also disable all controllers in the Controls settings of the sim, but that will also disable
mouse look and other mechanisms

3.2

Main Window
– Assigned Axis: list of all joystick axis that you
have assigned to this aircraft
+/-: to add or remove an axis assignment.
– Assigned Buttons: All or your button
assignments (Joystick, MIDI and keyboard). that
you added to this aircraft
+/-: to add or remove a button assignment.
– Disable simulator controllers: to disable or
reset individual controllers in the simulator
(requires restart)
– Manage Joysticks: special dialog to handle
changes to your physical controllers (replacing
joystick etc.)
Assignments for controllers that are not attached will
be highlighted in red

3.3

Handling joystick axis assignments

3.3.1. Assign a new axis
To assign a new axis to your aircraft, click on the green “+” below the axis list on the left. This will
open the assignment dialog

Select either
one of the pre-configured axis
OR
any assignable simulator event

Move the desired joystick axis
until it shows up in the textbox

Press “Add” to save this assignment or “Cancel” to discard it.

3.3.2. Calibrate an axis
Every assigned axis is calibrated directly on the main dialog, by hovering your mouse cursor over
the various controls and turning your mouse wheel.
Click on the triangle, hold
the mouse button down and
drag the mouse left/right to
make larger adjustments

Spin mouse wheel here to
adjust center point

Activate to reverse axis
movement

Spin mouse wheel here to
adjust left margin/deadzone

Activate and spin mouse
wheel to apply response
curve

Spin mouse wheel here to
adjust right margin/deadzone
Spin mouse wheel in the
grey are to adjust center
deadzone

3.3.3. Change an axis assignment

DOUBLECLICK

Spin mouse wheel to adjust
response curve shape

Press “Change” to save this assignment or “Cancel” to discard it.

Move the desired joystick axis
until it shows up in the textbox

3.3.4. Remove axis

Click on the control to select it
Hold “Ctrl” while clicking to select
more than one axis at the same time

Click “-” to remove the selected
controls

3.4

Handling button, MIDI and keyboard assignments

3.4.1. Assign a new button
To assign a new button to your aircraft, click on the green “+” below the Button list on the right.
Select the event that is to be sent when
the button is pressed
Select the event that is to be sent when
the button is released
Assign a virtual key sequence to be sent
when the button is pressed
Press the desired joystick button until it shows up in
the textbox
OR
move the desired control sending MIDI notes
OR

This is only relevant for keyboard
controls. Activate this if the simulator is
overriding your keyboard combo

Select if the event is to be repeated while
the button is held down and set the
desired speed

Press “Add” to save this assignment or “Cancel” to discard it.

Type keyboard keys a-z, 0-9, shift, ctrl, alt
Keyboard combinations must be input in sequence,
do not press all keys at the same time.
Example; For “Shift&Ctrl&F” you would press
“Shift”, release it, then press “Ctrl”, release that and
finally press “F”

3.4.2. Sending values to events
With some events you can send specific values when the button is pressed. Spin the mouse wheel
over the numerical control to the right of the selection box to set that value:

3.4.3. Virtual keys
If you assign a virtual key sequence to the button, the app will send those keys when the button is
pressed, simulating a keyboard input of those characters and keys. You can assign a sequence of keys
too.
In this example, the app would send
Shift&Ctrl, keep them active and then
send A – S – D in sequence, releasing Shift&Ctrl after the last character.
To assign a virtual key, activate the “Assign” checkbox. Your keyboard input will then be redirected
to the textbox on the left. Deactivate “Assign” to return to normal operations. Use “Clear” to remove
the assignment and clear the textbox.

3.4.4. The button assignment control on the main list
Repeat setting
Event when button is pressed

Assigned control

Event when button is released

Activity indicator

3.4.5. Change a button assignment

DOUBLECLICK

The “Change Button Assignment” dialog works the same way as the “Add” dialog (see chapter
3.4.1).
Press “Change” to save this assignment or “Cancel” to discard it.

3.4.6. Remove button assignments

Click on the control to select it
Hold “Ctrl” while clicking to select
more than one button at the same
time

Click “-” to remove the selected
controls

3.5

Using the event selection boxes

There are more than 1000 simulator events that could theoretically be triggered with a button press.
The combobox just lists all of them, please refer to the SDK documentations for the exact usage of
the “Event-IDs”. To make finding a specific event easier, you can just start typing the name of the
event on your keyboard, the list will try to scroll to those events that match your input.

3.6

Using Templates

You can save a joystick configuration as a “Template”, so you can apply them quickly to new
aircraft.
Saving a configuration as a Template
Once you have finished setting up your controls, use the top menu “Templates → Save current setup
as template”
Enter the name of your
new template

Or select an existing
template to overwrite

Save to the database

Delete the template
selected in the list

Applying a Template to your current aircraft
When your aircraft has been recognized, use the top menu “Templates → Apply a template to this
aircraft”

Doubleclick the desired
template

Or single click and press
“Apply”

Important note
Joystick assignments in AxisAndOhs are always individual assignments for each aircraft. A
change in the template will NOT update all aircraft configurations that were built with it.

Applying an existing configuration to your current aircraft
When your aircraft has been recognized, use the top menu “Templates → Apply other config to this
aircraft”

Doubleclick the source
aircraft

Or single click and press
“Apply”

Delete the configuration
selected in the list

4.

Enhanced Power Management (Win 8.1 and later)

The older USB devices will have issues when they are used with a computer that is running
Windows 8 or later, because of the “Enhanced Power Management” feature built into these operating
systems. The most notable case is the Saitek Multi Panel, where the display would light up, but not
show any text on it.
To help with this, you can disable the EPM using the “Win 8/10 Enhanced Power Managenet”
feature in the “Tools” menu.
On this dialog you will see all devices that LAAO
recognized and their current EPM status.
Turn EPM off if you experience issues with devices,
like missing functionality or the device constantly
connecting and disconnecting.

Note: to use this dialog it is necessary to
run the app “As Administrator”.

5.

Saitek Panels (Radio, Multi, Switch)

Lorby AxisAndOhs can manage the Saitek Radio-, Multi- and Switchpanel devices. When you select
“Enable Saitek” from the “Tools” menu, the app will search for attached devices and connect them
to the appropriate simulator events.
Radio panel special functionality:
• When in “DME” mode, the button switches between DME1 and DME2
• the “ADF” setting shows ADF1 on the left and ADF2 on the right. Use the button on the device
to switch between the rotary controller altering ADF1 or ADF2.
• In the XPDR setting, the device shows the transponder code on the left and the current QNH on
the right. Use the button to switch between editing the transponder code and adjusting the
Kohlsmann setting
◦ Editing the transponder code: the inner dial changes the numbers, the outer dial select the
digit to be altered
◦ Changing the Kohlsmann: the inner dial changes the value, the outer dial switches between
mb and inHg.
Note: it is not recommended to use special drivers or other Sateik tools at the same time. LAAO accesses the

devices at a very low operating level, so the default installation of the devices should suffice in most cases.

6.

Disable simulator controllers

The simulator has a “database” of many controllers. When you plug in a new joystick or similar
device, the simulator will try to match control assignments to this device based on the database. The
result is saved to the file “Standard.xml” in the simulators configuration directory
(AppData\Roaming\...). This is the same for all simulators from FSX boxed to P3D V4.x.
These assignments will get into conflict with what Lorby AxisAndOhs is trying to do, so they must
be disabled when they are triggering the same controls. There are several ways to do that:
– You can disable the conflicting axis or buttons in the Control assignment dialog of the
simulator.
– You can disable all external controllers in the simulator (there is a checkbox for that in the
control assignments dialogs of the sim). This has the drawback of disabling all controllers, even
the mouse (so mouse-look will no longer work)
Alternatively you can use the Lorby AxisAndOhs “Disable simulator controllers” feature:

This action is only possible when your simulator is not running!

Opening the combobox will show you all controller
assignments that the simulator is currently using.

After having selected one of them your can
choose to
– Disable selected in standard.xml:
this will remove all assignments to this controller
from the standard.xml file, but keep the definition
itself intact – so the sim will not restore the assignments on its own
– Reset selected group to default:
this will remove all references to the selected controller from the standard.xml. When you next start and
stop the simulator it will treat the controller as if it was a new one and restore the default settings.

7.

Manage joysticks

If you make changes to your controller setup, for example replace a joystick with a new one, replace
an USB hub etc., theoretically you would have to reassign all your controls.
To help with that, Lorby AxisAndOhs has a dialog that allows you to manually reassign or delete
controllers from the AxisAndOhs database. Changes aren't permanent until you press “Save”!

The list on the left
shows all joystick
devices that are
currently connected
to your computer

The list on the right
shows all joystick
devices that are
present in the
AxisAndOhs
database.
Devices that match
with a connected
joystick are shown
in green, devices
that are no longer
present are shown in
red
Doubleclick on a
line to get details
about where the
controller is
assigned exactly

-> Replace ->
With this button you can replace a joystick device in the database with a different (connected) one. The typical
use case would be that you have replaces a joystick or if Windows has decided to rearrange the USB devices
representing the joysticks (and your assignments no longer match the controller they were made for).
–
–
–
–
–

Select the new device in the left list
Select the device that is to be replaced in the right list
Press “- > Replace - >”
After a safety dialog, the app will replace the old joystick with the new one.
Press “Save” if you are happy with the changes.

Clear ->
With this button you can set a certain joystick device to represent an “empty” joystick. This is useful if you have
to make a replacement but already have the new device in the database, or if you want to disable a certain
controller.
–
–
–
–

Select the device that is to be cleared in the right list
Press “Clear - >”
After a safety dialog, the app will replace the old joystick with an empty device.
Press “Save” if you are happy with the changes.

Delete ->
This will completely remove the selected entry from the right list. Use this if you have assignments in the
database that are obsolete or that you are not using any more.
–
–
–
–

Select the device that is to be cleared in the right list
Press “Delete - >”
After a safety dialog, the app will delete the selected device from the database.
Press “Save” if you are happy with the changes.

Disconnecting and reconnecting joysticks
A device that is disconnected while the app is running is being ignored. When you reconnect it, you must direct
AxisAndOhs to scan for joystick devices (or just restart the app).
To scan for devices you can use the “Rescan Joysticks” button on the “Manage Joysticks” dialog.
Alternatively there is a shortcut in the “Tools” menu: click on “Scan for joysticks” to re-initialize.

8.

File handling

Database
Lorby AxisAndOhs is using a simple XML file to store all your joystick assignments. The file is named
differently for each simulator that you installed the app for, and it is located here:
“C:\Users\...\Documents\LorbyAxisAndOhs Files\”
The file is saved in 4 “generations”, so if something goes wrong you can return to an earlier state of the file by
renaming the n-th backup “ConfigDatabase_(sim-ID)_n.xml” to “ConfigDatabase_(sim-ID).xml”
Standard.xml
If you decide to disable components of the Standard.xml file (see chapter 4), AxisAndOhs will keep the original
file and an additional backup. You will find both these backups at the same location where your “Standard.xml”
is.
Examples:
“C:\Users\...\AppData\Roaming\Microsoft\FSX\Controls”
“C:\Users\...\AppData\Roaming\Lockheed Martin\Prepar3D v4\Controls”

9.

Make the app start automatically with your sim

For Prepar3D V4.x the installer is taking care of this. When you start your simulator after the installation of
AxisAndOhs is complete, you will be asked to activate the addon.
For all 32bit simulators you can either add the app to your exe.xml or add it to a third party management and
startup tool.
The exe.xml is located in “\AppData\Roaming\...” too, and the entry would look something like this:
<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
…
<Launch.Addon>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Name>LorbyAxisAndOhs</Name>
<Path>C:\Program Files (x86)\LorbyAxisAndOhs_SE\LorbyAxisAndOhs_SE.exe</Path>
<CommandLine></CommandLine>
<NewConsole>False</NewConsole>
</Launch.Addon>
</SimBase.Document>

These are the <Path> tags for the various simulators:

– FSX boxed:
<Path>C:\Program Files (x86)\LorbyAxisAndOhs\LorbyAxisAndOhs.exe</Path>

– FSX SteamEdition
<Path>C:\Program Files (x86)\LorbyAxisAndOhs_SE\LorbyAxisAndOhs_SE.exe</Path>

– P3D V2.5
<Path>C:\Program Files (x86)\LorbyAxisAndOhs_P3D\LorbyAxisAndOhs_P3D.exe</Path>

– P3D V3.x
<Path>C:\Program Files (x86)\LorbyAxisAndOhs_P3D_V3\LorbyAxisAndOhs_P3D_V3 .exe</Path>

10. Settings and Tools
The settings that can be selected for the app can be accessed in the top menu:
• “Connect” connects to the sim.
• “Connect automatically” does that when the app is started.
• “Minimize automatically” minimized the app to the task bar.

The “Tools” menu contains additional features
• “Win 8/10 EnhancedPowerManagement” see chapter 4
• “Scan for joysticks” is only required when you attach a new joystick
while the app is running.
• “Scan for Saitek Panels” will reset the current configuration and scan for new panels
• “MIDI devices enabled” controls if the app should use your MIDI devices
• “Saitek panels enabled” controls if the app should use your Saitek Radio-, Multi- and Switchpanels

11.

Disclaimer

Lorby AxisAndOhs is provided free of charge, for private use only. All property rights remain with the author.
You may not distribute this package or parts of it. Disassembling, refactoring or changes of any kind are
prohibited.
Disclaimer of Warranties. The author disclaims to the fullest extent authorized by law any and all other
warranties, whether express or implied, including, without limitation, any implied warranties of title, noninfringement, merchantability or fitness for a particular purpose. Without limitation of the foregoing, the
author expressly does not warrant that:
• the software will meet your requirements or expectations;
• the software or the software content will be free of bugs, errors, viruses or other defects;
• any results, output, or data provided through or generated by the software will be accurate, up-to-date,
complete or reliable;
• the software will be compatible with third party software;
• any errors in the software will be corrected or that any further development will take place;
• the software will not cause errors or damage to the computer system it is installed on.
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